Driveshell forum


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

4 Pages<1234>
Options
Go to last post Go to first unread
marlo  
#41 Posted : Tuesday, September 20, 2016 8:51:47 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
Just a question:

so when you set IGO to AUTOSTART in plugin settings...
...after launch of DS you can see IGO embedding and as well you can see the windows taskbar.
Both just for a few seconds.

You know what I mean,right?

Thats not a big thing but it looks not really good,I think.


Now the question:

When you delay the start of IGO a bit,would it solve that?

I mean when DS is started,just a delay about 2 or 3 seconds before IGO will autostart?
Admin (Lasse)  
#42 Posted : Friday, September 23, 2016 11:55:44 AM(UTC)
Admin (Lasse)

Rank: Administration

Groups: Administrators
Joined: 9/16/2015(UTC)
Posts: 1,325
Man
Denmark

Thanks: 10 times
Was thanked: 61 time(s) in 50 post(s)
Originally Posted by: marlo Go to Quoted Post
Just a question:

so when you set IGO to AUTOSTART in plugin settings...
...after launch of DS you can see IGO embedding and as well you can see the windows taskbar.
Both just for a few seconds.

You know what I mean,right?

Thats not a big thing but it looks not really good,I think.


Now the question:

When you delay the start of IGO a bit,would it solve that?

I mean when DS is started,just a delay about 2 or 3 seconds before IGO will autostart?


Yeah, it's not pretty, i know.. i hoped to have it initialize in a hidden window so it won't show at all until you need it.. i will have to work more on that.

fuusob  
#43 Posted : Friday, September 23, 2016 2:15:35 PM(UTC)
fuusob

Rank: Advanced Member

Groups: Registered
Joined: 5/5/2016(UTC)
Posts: 69
United States
Location: Virginia

Thanks: 1 times
With the igo plugin folder moved, is there a way to change the comm pirt for the gps reciever in DS and have it save the change?
Admin (Lasse)  
#44 Posted : Friday, September 23, 2016 2:27:49 PM(UTC)
Admin (Lasse)

Rank: Administration

Groups: Administrators
Joined: 9/16/2015(UTC)
Posts: 1,325
Man
Denmark

Thanks: 10 times
Was thanked: 61 time(s) in 50 post(s)
Hi fuusob, have you tried through the settings of igo plugin?
fuusob  
#45 Posted : Friday, September 23, 2016 2:44:20 PM(UTC)
fuusob

Rank: Advanced Member

Groups: Registered
Joined: 5/5/2016(UTC)
Posts: 69
United States
Location: Virginia

Thanks: 1 times
Do you mean altering the files of the plugin or through the igo menu? I have tried through the igo menu, it works but I have to reset it every time. I have not tried altering the files.

Edited by user Friday, September 23, 2016 2:45:01 PM(UTC)  | Reason: Not specified

marlo  
#46 Posted : Friday, September 23, 2016 3:15:08 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
try that:
do the com setting in IGO.

when settings are done,close IGO with the exit button.

I mean the exit button of IGO.

NOT DS
fuusob  
#47 Posted : Friday, September 23, 2016 3:42:54 PM(UTC)
fuusob

Rank: Advanced Member

Groups: Registered
Joined: 5/5/2016(UTC)
Posts: 69
United States
Location: Virginia

Thanks: 1 times
I have tried that method and it still defaults to comm port 3. I think I gave myself full privileges to app data, but I'll check to be sure

marlo  
#48 Posted : Friday, September 23, 2016 4:03:43 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
do you run IGO.EXE as ADMIN?
marlo  
#49 Posted : Friday, September 23, 2016 9:01:47 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)



Okay fuusob ;)

go to the install folder of IGO.
There is a file called "SYS_PC"

open it with editor and edit your com port setting there.
Save the changes.


Should Work :)
marlo  
#50 Posted : Friday, September 23, 2016 9:08:13 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
Lasse,

the settings for com port and baud rate in the igo PLUGIN :

When I change the baud rate there,it overwrites the baud settings in SYS_PC.txt

Thats good.


BUT when I try to change the com port in PLUGIN settings it has no effect.




At the moment its just WHAT com port is setted in the PLUGIN that is written in SYS_PC.txt.

So changes in IGO settings have no effect because IGO looks in SYS_PC.txt for gps settings,you know.
marlo  
#51 Posted : Friday, September 23, 2016 9:10:10 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
Forgot something:

Setting IGO.exe to admin is NOT NEEDED.
marlo  
#52 Posted : Friday, September 23, 2016 9:13:48 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
The prob for now is just that the com port in PLUGIN SETTING is setted as COM3.
In PLUGIN SETTINGS it can not be changed.


That means in SYS_PC.txt the com port is also COM3.

IGO uses always the settings of SYS_PC.txt ;)
fuusob  
#53 Posted : Friday, September 23, 2016 9:18:54 PM(UTC)
fuusob

Rank: Advanced Member

Groups: Registered
Joined: 5/5/2016(UTC)
Posts: 69
United States
Location: Virginia

Thanks: 1 times
Not sure how to run it as admin since DS launches it?
marlo  
#54 Posted : Friday, September 23, 2016 9:22:38 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
NOT NEEDED to run as admin.

Go to the Path where IGO is located.

EDIT SYS_PC.txt
marlo  
#55 Posted : Friday, September 23, 2016 9:26:21 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
fuusob  
#56 Posted : Saturday, September 24, 2016 1:01:58 AM(UTC)
fuusob

Rank: Advanced Member

Groups: Registered
Joined: 5/5/2016(UTC)
Posts: 69
United States
Location: Virginia

Thanks: 1 times
That worked! Thanks marlo
marlo  
#57 Posted : Saturday, September 24, 2016 8:39:04 AM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
Originally Posted by: fuusob Go to Quoted Post
That worked! Thanks marlo


Alright.
Great :)
marlo  
#58 Posted : Saturday, September 24, 2016 12:34:15 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
Something:

You can set the com port and baud rate from inside IGO itself.


Here i mean:



After you have done your settings you must close IGO with its exit button.
That way IGO overwrites the file SYS_PC.txt.





BUT to get that methode working, IGO.EXE MUST run as ADMIN.

Exactly there is a problem.

When I set IGO.EXE to run as ADMIN,I get an error message from DS..

IGO PLUGIN fails to load..
marlo  
#59 Posted : Saturday, September 24, 2016 12:37:51 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
That just means:

FOR NOW,you guys have to edit the file "SYS_PC.txt" MANUALLY to change com settings.
The setting for baud rate works in DS.
But not in IGO settings.


As said...IGO MUST run as ADMIN to overwrite the file "SYS_PC.txt".
marlo  
#60 Posted : Saturday, September 24, 2016 1:50:55 PM(UTC)
marlo

Rank: Advanced Member

Groups: Registered
Joined: 9/18/2015(UTC)
Posts: 1,564
Man
Germany
Location: Germany

Thanks: 46 times
Was thanked: 19 time(s) in 17 post(s)
Hmmmm,

forget what I have said above...

I did a few tests with IGO itself.

So outside from DS,i mean.



Trying to change com or baud does NOT WORK at all.

There is no way to get IGO to overwrite the SYS_PC.txt file.

Even when IGO runs as admin it do NOT WORK.

IGO has full user permissions and nothing seems to be write protected by windows.



Its strange because on WINDOWS 7 it runs fine.
And when i had changed settings in IGO it has overwritten SYS_PC.txt.



Looks Like that is a WINDOWS 10 issue and NOT related to DriveShell.


I don´t know.

Anyway com and baut settings are not used very often,I think.


So guys,just edit SYS_PC.txt MANUALLY and you are done :)



No big prob,I mean ;)
Users browsing this topic
4 Pages<1234>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.